foshkplugin.conf einrichten

Für Linuxbenutzer und -begeisterte
wetterkunde
Offline
Beiträge: 10
Registriert: 17 Feb 2022, 17:09

foshkplugin.conf einrichten

#1

Beitrag von wetterkunde »

Hallo zusammen,
habe mir gerade weewx auf meinem Server installiert.
Da meine Wetterstation WH2900 sich nicht auf weewx einrichten lässt,
Habe ich noch FOSHKplugin Installiert.
Jetzt muss die foshkplugin.conf noch eingerichtet werden.

[Forward-1]
FWD_ENABLE = True
FWD_CMT =
FWD_URL =
FWD_INTERVAL = 60
FWD_IGNORE =
FWD_TYPE = WU
FWD_SID =
FWD_PWD =
FWD_STATUS = False
FWD_MQTTCYCLE = 0
FWD_EXEC =

Ich habe hierzu noch nichts gefunden. Könnt Ihr mir da bitte weiterhelfen?

Merci für Eure Hilfe.
Gruss
Swen
Benutzeravatar
olicat
Offline
Beiträge: 1307
Registriert: 07 Dez 2020, 19:33
Wohnort: Hohen Neuendorf
Hat sich bedankt: 16 mal
Danksagung erhalten: 230 mal
Kontaktdaten:

Re: foshkplugin.conf einrichten

#2

Beitrag von olicat »

Hi!
Da meine Wetterstation WH2900 sich nicht auf weewx einrichten lässt,
Warum? Vielmehr, woraus schliesst Du das?
Jetzt muss die foshkplugin.conf noch eingerichtet werden.
Was genau ist denn Dein Ziel? Wozu wolltest Du also weewx und FOSHKplugin installieren?
Eine umfangreiche Anleitung mit sehr vielen Beispielen findest Du hier.

Wenn Du mitteilst, was genau Du eigentlich in welcher Form ausgeben moechtest, koennte ich Dir da sicher weiterhelfen.

Oliver
wetterkunde
Offline
Beiträge: 10
Registriert: 17 Feb 2022, 17:09

Re: foshkplugin.conf einrichten

#3

Beitrag von wetterkunde »

Hallo Oliver ich möchte die Daten von der Wetterstation auf der Internetseite poehlwetter.ddns.net/public_html ausgeben. Die Seite läuft mit weewx jetzt ist auf Simulation eingestellt.
Benutzeravatar
olicat
Offline
Beiträge: 1307
Registriert: 07 Dez 2020, 19:33
Wohnort: Hohen Neuendorf
Hat sich bedankt: 16 mal
Danksagung erhalten: 230 mal
Kontaktdaten:

Re: foshkplugin.conf einrichten

#4

Beitrag von olicat »

Hi!

Wenn Du die Daten Deiner Wetterstation nach weewx bringen moechtest, benoetigst Du FOSHKplugin nicht zwingend.
Das wird dann erst interessant, wenn Du die Daten an mehrere parallele Ziele versenden willst.
Insofern solltest Du Dich erstmal nicht weiter mit FOSHKplugin beschaeftigen sondern Dich auf weewx konzentrieren.

Allerdings - da Du ja schon erste Misserfolge hattest - solltest Du ein paar grundlegende Dinge klaeren:

1. ist die Wetterstation in der App WS View (Android, iOS) sichtbar?
2. ist die Firmware der Wetterstation aktuell?
3. hast Du den weewx-Interceptor installiert? siehe: https://www.wxforum.net/index.php?topic=37471.0
4. hast Du innerhalb von WS View den custom server zum Versand der Daten im Ecowitt-Protokoll zu weewx auf den korrekten Port eingestellt?
5. kann der Host mit weewx die Wetterstation anpingen?

Hintergrund:
Die Wetterstation muss so eingestellt werden, das sie die Daten in korrekter Form (Ecowitt) an das richtige Ziel (IP, Port) im festgelegten Intervall sendet. weewx wiederum muss so konfiguriert werden, das es die Daten der Wetterstation annimmt und verarbeitet.
Das grundsaetzliche Funktionieren des custom server laesst sich recht schnell ueber den EAR-Service feststellen.
Dort gibt es auch ein paar Erklaerungen, wie der custom server einzurichten ist. Genau so muss das dann auch fuer weewx eingerichtet werden. Nur muss dann natuerlich das Ziel nicht mehr ear.phantasoft.de sein sondern die IP-Adresse Deines weewx-Hosts. Und der Port (bei EAR: 80) ist fuer weewx sehr wahrscheinlich 8000.

Oliver
Benutzeravatar
olicat
Offline
Beiträge: 1307
Registriert: 07 Dez 2020, 19:33
Wohnort: Hohen Neuendorf
Hat sich bedankt: 16 mal
Danksagung erhalten: 230 mal
Kontaktdaten:

Re: foshkplugin.conf einrichten

#5

Beitrag von olicat »

Hi!

Eine WS2900 mit aktueller WIFI-Firmware v1.6.1 und 868MHz hat sich gestern zwischen 21:44 (UTC) und 22:17 (UTC) erfolgreich bei EAR gemeldet.
Ich gehe davon aus, das dies Deine Station war und diese somit in der Lage ist, ueber custom server und Interceptor-Treiber auch weewx Daten bereitzustellen.

Oliver
wetterkunde
Offline
Beiträge: 10
Registriert: 17 Feb 2022, 17:09

Re: foshkplugin.conf einrichten

#6

Beitrag von wetterkunde »

Ja das war ich :D
Ich habe den weewx-Interceptor installiert.
Wenn ich jetzt die Parameter für den Interceptor in der weewx.conf festlege, dann startet weewx nicht mehr.
Ich habe folgendes in die weewx.conf eingefügt.

[Interceptor]
# This section is for the network traffic interceptor driver.

# The driver to use:
driver = user.interceptor
device_type = observer
port = 8000

[Interceptor]
driver = user.interceptor
device_type = lw30x
port = 8080
address = 192.168.2.121

[Interceptor]
driver = user.interceptor
device_type = acurite-bridge
mode = sniff
iface = eth1
pcap_filter = src 192.168.2.121 and dst port 80

[Interceptor]
driver = user.interceptor
device_type = ecowitt-client

Was habe ich da falsch gemacht?

Gruß Swen
Benutzeravatar
Werner
Offline
Beiträge: 66
Registriert: 07 Dez 2020, 17:23
Wohnort: Lackenhäuser
Danksagung erhalten: 12 mal
Kontaktdaten:

Re: foshkplugin.conf einrichten

#7

Beitrag von Werner »

So sollte es in der weewx.conf sein:

Code: Alles auswählen

[Station]
     # Set to type of station hardware. There must be a corresponding stanza
    # in this file with a 'driver' parameter indicating the driver to be used.
    station_type = Interceptor

[Interceptor]
    # This section is for the network traffic interceptor driver.
    
    # The driver to use:
    driver = user.interceptor
    
    device_type = ecowitt-client
    port = 8573  # diese Portnummer weil die Daten via FOSHKplugin kommen, default wäre 80
    iface = eth0
    #iface = wlan0 
    [[sensor_map_extensions]]
        co2 = co2
        co2_Temp = tf_co2
        co2_Hum = humi_co2
        co2_Batt = co2_batt
    ...
Die "sensor_map_extensions" sind für meine Belange eingerichtet ;)
wetterkunde
Offline
Beiträge: 10
Registriert: 17 Feb 2022, 17:09

Re: foshkplugin.conf einrichten

#8

Beitrag von wetterkunde »

Ich habe die weewx.conf jetzt so abgeändert.
Die weewx läst sich noch nicht starten
ich habe hier die Fehlermeldung aus dem journalctl -xe

Code: Alles auswählen

-- Subject: A start job for unit weewx.service has begun execution
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- A start job for unit weewx.service has begun execution.
--
-- The job identifier is 80134.
Feb 18 14:18:20 ncserver weewxd[216567]: Error parsing config file: Parsing failed with several errors.
Feb 18 14:18:20 ncserver weewxd[216567]: First error at line 65. File /home/weewx/weewx.conf
Feb 18 14:18:20 ncserver weewxd[216567]:     ****  Traceback (most recent call last):
Feb 18 14:18:20 ncserver weewxd[216567]:     ****    File "/home/weewx/bin/weewxd", line 88, in main
Feb 18 14:18:20 ncserver weewxd[216567]:     ****      config_path, config_dict = weecfg.read_config(options.config_path, list(args))
Feb 18 14:18:20 ncserver weewxd[216567]:     ****    File "/home/weewx/bin/weecfg/__init__.py", line 142, in read_config
Feb 18 14:18:20 ncserver weewxd[216567]:     ****      config_dict = configobj.ConfigObj(config_path,
Feb 18 14:18:20 ncserver weewxd[216567]:     ****    File "/usr/lib/python3/dist-packages/configobj.py", line 1229, in __init__
Feb 18 14:18:20 ncserver weewxd[216567]:     ****      self._load(infile, configspec)
Feb 18 14:18:20 ncserver weewxd[216567]:     ****    File "/usr/lib/python3/dist-packages/configobj.py", line 1318, in _load
Feb 18 14:18:20 ncserver weewxd[216567]:     ****      raise error
Feb 18 14:18:20 ncserver weewxd[216567]:     ****  configobj.ConfigObjError: Parsing failed with several errors.
Feb 18 14:18:20 ncserver weewxd[216567]:     ****  First error at line 65. File /home/weewx/weewx.conf
Feb 18 14:18:20 ncserver systemd[1]: weewx.service: Control process exited, code=exited, status=2/INVALIDARGUMENT
-- Subject: Unit process exited
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- An ExecStart= process belonging to unit weewx.service has exited.
--
-- The process' exit code is 'exited' and its exit status is 2.
Feb 18 14:18:20 ncserver systemd[1]: weewx.service: Failed with result 'exit-code'.
-- Subject: Unit failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- The unit weewx.service has entered the 'failed' state with result 'exit-code'.
Feb 18 14:18:20 ncserver systemd[1]: Failed to start weewx weather system.
-- Subject: A start job for unit weewx.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- A start job for unit weewx.service has finished with a failure.
--
-- The job identifier is 80134 and the job result is failed.
lines 2674-2715/2715 (END)
Benutzeravatar
olicat
Offline
Beiträge: 1307
Registriert: 07 Dez 2020, 19:33
Wohnort: Hohen Neuendorf
Hat sich bedankt: 16 mal
Danksagung erhalten: 230 mal
Kontaktdaten:

Re: foshkplugin.conf einrichten

#9

Beitrag von olicat »

Hi!
Feb 18 14:18:20 ncserver weewxd[216567]: **** First error at line 65. File /home/weewx/weewx.conf
Dann schau doch bitte mal, was in Zeile 65 Deiner weewx.conf steht?

Oliver
wetterkunde
Offline
Beiträge: 10
Registriert: 17 Feb 2022, 17:09

Re: foshkplugin.conf einrichten

#10

Beitrag von wetterkunde »

in Zeile 65 steht [Station]

Code: Alles auswählen

[Station]
     # Set to type of station hardware. There must be a corresponding stanza
    # in this file with a 'driver' parameter indicating the driver to be used.
    station_type = Interceptor
Antworten