FOSHKplugin

Für Geräte von froggit
Floridadriver
Offline
Beiträge: 46
Registriert: 14 Nov 2021, 14:06

Re: FOSHKplugin

#101

Beitrag von Floridadriver »

Hi Oliver,

Danke, mit deiner Hilfe bin ich schon weitergekommen. Nachstehend die Install Info, wie ist der nächste Schritt für mich?
Für eure Unterstützung bin ich echt dankbar, ohne die ging einfach nichts.
Install-Info.rtf
(52.36 KiB) 14-mal heruntergeladen
Michael
Benutzeravatar
olicat
Offline
Beiträge: 914
Registriert: 07 Dez 2020, 19:33
Wohnort: Hohen Neuendorf
Hat sich bedankt: 12 mal
Danksagung erhalten: 171 mal
Kontaktdaten:

Re: FOSHKplugin

#102

Beitrag von olicat »

Hi!
wie ist der nächste Schritt für mich?
Du solltest die Installation/Konfiguration abschliessen:

+++ FOSHKplugin +++ ip address of target system to send UDP-messages to []:
Leave blank if no UDP forwarding is required, otherwise enter the IP address of the destination of the UDP messages.
ENTER
+++ FOSHKplugin +++ udp port on target system []:
Leave blank if no UDP forwarding is required, otherwise enter the UDP port of the target system.
ENTER
+++ FOSHKplugin +++ ip address of local system [192.168.15.237]:
Enter the IP address of the local system, i.e. the device on which FOSHKplugin is to run (please do not use an IPv6 or localhost address).
gib hier die IP-Adresse Deines Windows-Rechner an
+++ FOSHKplugin +++ http port on local system [8080]:
The local port on which the internal http server is started by FOSHKplugin, the default can be accepted with ENTER.
ENTER
+++ FOSHKplugin +++ ip address of weather station [192.168.15.215]:
Please enter the IP address of the weather station here. This is generally found automatically.
trage hier die IP-Adresse Deiner Wetterstation ein
+++ FOSHKplugin +++ command port of weather station [45000]:
The command port of the weather station. Here, too, the default 45000 (the default port for FOSHK weather stations) can be accepted with ENTER.
45000
+++ FOSHKplugin +++ message-interval of weather station [30]:
Enter the desired interval in seconds at which the weather station sends the data to FOSHKplugin. The default of 30 seconds can be accepted - however, other time intervals can also be used. Note that this is also the minimum time interval for forwards.
60
+++ FOSHKplugin +++ are these settings ok? (Y/N)
The settings made are accepted with Y. With N it can be configured again if an error is discovered.
Y
+++ FOSHKplugin +++ do you want to write settings into the config-file? (Y/N)
With Y these settings are written into the config file (foshkplugin.conf).
Y
+++ FOSHKplugin +++ do you want to write settings into the weather station? (Y/N)
With Y the required data (IP address and port of the target system from the perspective of the weather station, the interval and the data format Ecowitt) are written to the weather station.
N
+++ FOSHKplugin +++ do you want to enable and start the service? (Y/N)
With Y, a service (foshkplugin) is installed and started, which is started automatically every time the computer is restarted and which leads to the restart of FOSHKplugin within a few seconds even if the program crashes.
Y

Anschliessend must Du noch etwas "Feinschliff" im Config-File machen.

Code: Alles auswählen

nano foshkplugin.conf
Suche dort den Eintrag
LOX_IP =
und entferne alles hinter dem =.
Zusaetzlich solltest Du dann noch die fuer Dich relevanten Forwards eintragen. Fuer PWT etwa so:

Code: Alles auswählen

[Forward]
FWD_ENABLE = True
FWD_CMT = Datenversand an PWT
FWD_URL = http://xxx.xxx.xxx.xxx:8572/  # (xxx.xxx.xxx.xxx ist die IP Adresse des Tablets, auf dem PWT läuft)
FWD_TYPE = RAWEW
Schliesslich muss Dein Windows-Port 8080 noch auf den WSL-Port 8080 umgeleitet werden.
Dazu bitte die Eingabeaufforderung als Administrator auf dem Windows-Rechner starten (per Rechtsklick) und dort eintragen:

Code: Alles auswählen

netsh interface portproxy add v4tov4 listenport=8080 listenaddress=0.0.0.0 connectport=8080 connectaddress=127.0.0.1
Mit WS View ist noch die Wetterstation einzustellen (leider klappt das bei der WSL-Loesung nicht automatisch):
Wetterstation auswaehlen
oben rechts of More klicken
Weather Services anklicken
4 mal auf rechts oben Next klicken, bis Customized angezeigt wird
Enable
Ecowitt
IP-Adresse Deines Windows-Rechners
/data/report/
8080
60
Save
oben rechts au Finsh klicken

Jetzt solltest Du auf dem Windows-Rechner per Webbrowser mit der URL http://localhost:8080/status&minmax sehen koennen, ob irgendwelche Pakete der Wetterstation eingehen. Wenn ja ist das soweit erfolgreich verlaufen und Du kannst PWT auf einem Tablet installieren.
Oder weitere Forwards in der foshkplugin.conf konfigurieren.

Viel Erfolg!

Oliver
Zuletzt geändert von olicat am 11 Jan 2022, 09:31, insgesamt 1-mal geändert.
Floridadriver
Offline
Beiträge: 46
Registriert: 14 Nov 2021, 14:06

Re: FOSHKplugin

#103

Beitrag von Floridadriver »

Oliver,
vielen Dank, jetzt sollte ich es schaffen. Gibt es irgendwo eine Kaffeekasse? Ich soviel Unterstützung erhalten und möchte mich bedanken.

Ich werde berichten ob alles geklappt hat, wird jedoch Donnerstag werden.

Michael
Floridadriver
Offline
Beiträge: 46
Registriert: 14 Nov 2021, 14:06

Re: FOSHKplugin

#104

Beitrag von Floridadriver »

Guten Morgen,
ich wollte meine Installation fertigstellen, muss ich dafür die Installation neu starten
sudo chmod u+x generic-FOSHKplugin-install.sh
sudo ./generic-FOSHKplugin-install.sh --install
oder
wie setze ich die abgebrochen Installation fort.
Wie gebe ich, sofern alles läuft weitere forwards ein
1) weiteres PWT
2) WU
https://rtupdate.wunderground.com/weath ... on.php?ID=[meine ID]&PASSWORD=[my password]&action=updateraw&
Benutzeravatar
Gyvate
Offline
Beiträge: 417
Registriert: 10 Aug 2021, 21:41
Hat sich bedankt: 1 mal
Danksagung erhalten: 50 mal
Kontaktdaten:

Re: FOSHKplugin

#105

Beitrag von Gyvate »

1.

Code: Alles auswählen

sudo ./generic-FOSHKplugin-install.sh --install
sollte genügen - das Installationsskript hat ja schon von letzten Mal bereits die passenden Berechtigungen.

Wenn Du allerdings bereits einmal installiert hast, brauchst Du normalerweise die Installation nicht zu wiederholen, sondern nur noch Änderungen, Ergänzung in foshkplugin.conf vornehmen.

2. weitere forwards werden einfach in der foshkplugin.conf Datei eingetragen
Beispiele auf @olicats Webseite
https://loxwiki.atlassian.net/wiki/spac ... ic+version
z.B. mit dem nano Editor vornehmen

Code: Alles auswählen

 sudo nano ./foshkpludin.conf  
(wenn Du Dich im selben Verzeichnis wie die foshkplugin.conf befindest - anderenfalls entweder mit cd in das Verzeichnis wechseln oder den Pfad in das Kommando aufnehmen).
nach der Änderung muss foshkplugin neu gestartet werden

Code: Alles auswählen

sudo service foshkplugin restart 
WH4000SE/WS2320E, HP1000SE Pro/HP2553, GW2001 - DP1500, GW1100, GW1000, WH2650, Meteobridge RPi 2/16 2671, Weewx 4.5.1, CumulusMX 3160 - http://meshka.eu
Floridadriver
Offline
Beiträge: 46
Registriert: 14 Nov 2021, 14:06

Re: FOSHKplugin

#106

Beitrag von Floridadriver »

Hallo, ich verzweifle,
jetzt kommt bei nano die Meldung "Directory '.' is not writable" Ich kann keine Zeile editieren.
Habe mich mit meinem Passwort, sudo angemeldet und die Installation ging bis jetzt ohne Probleme.

Michael
Floridadriver
Offline
Beiträge: 46
Registriert: 14 Nov 2021, 14:06

Re: FOSHKplugin

#107

Beitrag von Floridadriver »

Hallo,
habe den Rechner neu gestartet und ich konnte die conf editieren.
sudo service foshkplugin hat nicht funktioniert
Abruf localhost ebenfalls nicht
PWT ebenfalls nicht, irdendwo ist der "Wurm" drin
Ich warte mal ab ob forward zu WU funktioniert. Stand: online (update 13minutes ago)
Habe bei WU in der conf FWD_Type = (unverändert, ohne Eintrag gelassen)

Alles in allem nach 5 Stunden sieht es nicht gut aus uns meine Frau ist "sauer"

Michael
Benutzeravatar
Gyvate
Offline
Beiträge: 417
Registriert: 10 Aug 2021, 21:41
Hat sich bedankt: 1 mal
Danksagung erhalten: 50 mal
Kontaktdaten:

Re: FOSHKplugin

#108

Beitrag von Gyvate »

Floridadriver hat geschrieben: 14 Jan 2022, 17:38 Hallo, ich verzweifle,
jetzt kommt bei nano die Meldung "Directory '.' is not writable" Ich kann keine Zeile editieren.
Habe mich mit meinem Passwort, sudo angemeldet und die Installation ging bis jetzt ohne Probleme.

Michael
Diese Meldung kommt üblicherweise, wenn man ohne die notwendige Berechtigung mit nano (Editor) eine (z.B. System-)Datei öffnet.
Mit
sudo nano .....
wird das vermieden. 8-)
WH4000SE/WS2320E, HP1000SE Pro/HP2553, GW2001 - DP1500, GW1100, GW1000, WH2650, Meteobridge RPi 2/16 2671, Weewx 4.5.1, CumulusMX 3160 - http://meshka.eu
Benutzeravatar
Gyvate
Offline
Beiträge: 417
Registriert: 10 Aug 2021, 21:41
Hat sich bedankt: 1 mal
Danksagung erhalten: 50 mal
Kontaktdaten:

Re: FOSHKplugin

#109

Beitrag von Gyvate »

Floridadriver hat geschrieben: 14 Jan 2022, 19:00 Hallo,
habe den Rechner neu gestartet und ich konnte die conf editieren.
sudo service foshkplugin hat nicht funktioniert
Abruf localhost ebenfalls nicht
.....
Michael
Der Befehl ist unvollständig.
Er müsste lauten
sudo service foshkplugin start
bzw. restart, stop, status ...
Abruf local host wäre dann
http://localhost:8080 (bzw. die Portnummer, die Du gewählt hast)
nur http://localhost frägt den Port 80, den Standard http-Port ab - wo sich wahrscheinlich nichts befindet.
Du solltest allerdings zuvor auch einen Webserver installiert haben (nginx oder apache2; sudo apt install apache2),
sonst bewegt sich auf Port 80 nichts. (Für FOSHKplugin oder CMX allein ist der Webserver nicht nötig, da FOSHKplugin selbst wie ein mini-Webserver funktioniert.)
Ansonsten ist dann wohl die Installation nicht richtig gelaufen.
Wiederholen - genau nach Installationsanweisung - hilft oft ;)
Zuletzt geändert von Gyvate am 14 Jan 2022, 20:00, insgesamt 1-mal geändert.
WH4000SE/WS2320E, HP1000SE Pro/HP2553, GW2001 - DP1500, GW1100, GW1000, WH2650, Meteobridge RPi 2/16 2671, Weewx 4.5.1, CumulusMX 3160 - http://meshka.eu
Floridadriver
Offline
Beiträge: 46
Registriert: 14 Nov 2021, 14:06

Re: FOSHKplugin

#110

Beitrag von Floridadriver »

Danke,
nachstehend meine conf Datei
foshkplugin_conf.txt
(3.72 KiB) 15-mal heruntergeladen
Michael
Antworten